FAQ: What browsers work best with this site?

This site works best with Microsoft Internet Explorer, version 9.0 or higher, and more recent versions of Firefox, Chrome, and Safari. The reason for incompatibility with earlier versions of some browsers has to do with the JavaScript programming that is used to make the Active Searches page work.

You can get browser upgrades at the following sites:

Return to FAQ Menu